Nowadays, when access layer switches have 1GB ports, increasing the number of an upstream links to the distribution layer is necessary. Let’s have a look on etherchannel feature, the way that we may achieve that and how to configure its on layer 2 and 3.
Etherchannel (aggregation) feature takes a few physical links and bundle them into single logical link. Take a look on below topology. There are 4 physical links bundled together, but for both switches these links are visible as a one single link. Thanks to this we may avoid loops, because even for Spanning Tree Protocol these 4 links are visible as a one single link. So, we get 4 Gbit link without any negative implications!
There are 3 ways that we may configure Etherchannel: PAgP, LACP and statically. If we use protocols we have to make sure that on both sides of the each physical link interfaces have: the same duplex, speed, same native and allowed Vlans and switchport mode (access or trunk). LACP is Cisco proprietary but PAgP is widespread much more, even not all Cisco platforms support LACP. PAgP provides 4 options regarding link configuration:
– ON (interface becomes the part of etherchannel unconditionally)
– DESIRABLE (interface actively ask for becoming the etherchannel)
– AUTO (interface passively wait for asking from the other side)
– OFF (no etherchannel)
Etherchannel may be deployed on layer 2 or layer 3.
Layer 2 ETHERCHANNEL configuration:
SW1
interface range ethernet 0/0-3
channel-group 1 mode auto
SW2
interface range ethernet 0/0-3
channel-group 1 mode desirable
2. Next, “Port-channel 1” interface will be created automatically, that we will be working with. Let’s set up its as a “trunk”
interface port-channel 1
switchport trunk encapsulation dot1q
switchport mode trunk
Let’s verify if we have aggregation link established
Layer 3 ETHERCHANNEL Configuration
Firstly let’s turn on L3
ip routing
Next I added port to Vlan 100 and I’ve run SVI
interface g1/0
switchport mode access
switchport access vlan 100
interface vlan 100
ip address 192.168.1.100 255.255.255.0
no shut
Now there is a difference to compare with Layer 2 etherchannel, because we have to create interface port-channel first
interface port-channel 1
no switchport
ip address 172.16.0.1 255.255.255.0
no shut
Now we assigne desire interfaces to the port channel interface
interface range g0/0-3
no switchport
channel-group 1 mode on
no shut
and adding the route to the network onthe other side
ip route 192.168.2.0 255.255.255.0 172.16.0.2
SWITCH2
ip routing
interface g1/0
switchport mode access
switchport access vlan 200
interface vlan 200
ip address 192.168.2.100 255.255.255.0
no shut
interface port-channel 1
no switchport
ip address 172.16.0.2 255.255.255.0
no shut
interface range g0/0-3
no switchport
channel-group 1 mode on
no shut
ip route 192.168.1.0 255.255.255.0 172.16.0.1
Let’s verify
LOAD BALANCING
Now, let’s go over another important thing. Ok, we have one logical link but there are 4 physical links, a single packet can’t be chopped onto 4 pieces and send further. Etherchanel makes decision about sending the packet via particular physical link based on 4 modes:
dst-ip based on destination IP address
dst-mac based on destination MAC address
src-dst-ip based on source OR destination IP address
src-dst-mac based on source OR destination MAC address
src-ip based on source IP address
src-mac based on source MAC address
We may influence on load balancing with a command “port-channel load balance [MODE]“